You need Flash version 9.0.23 or higher to view this site. We target 9.0.23 because 9.0.16 has so many issues with video events.